facebook twitter hatena line google mixi email

Unity/photon/2018.2error

提供: 初心者エンジニアの簡易メモ
2019年9月11日 (水) 01:19時点におけるAdmin (トーク | 投稿記録)による版

移動: 案内検索

"removed in Unity 2018.2. Use Unity Multiplayer and NetworkIdentity instead photon"エラー

以下からgoogle-arインストールすると治る。

https://github.com/google-ar/arcore-unity-sdk/releases/tag/v1.4.1

参考:https://github.com/google-ar/arcore-unity-sdk/issues/197


if (method.IsDefined(typeof (RPC), false))エラー

if (method.IsDefined(typeof (PunRPC), false))

へ変換

参考:https://forum.unity.com/threads/disable-unityengine-rpc-is-obsolete-spam.337395/

else if (!InternalEditorUtility.HasAdvancedLicenseOnBuildTarget(BuildTarget.Android) || !InternalEditorUtility.HasAdvancedLicenseOnBuildTarget(BuildTarget.iPhone))エラー

else if (!InternalEditorUtility.HasAdvancedLicenseOnBuildTarget(BuildTarget.Android))

へ変更

参考:https://qiita.com/jtky8238/items/54cbf0d58d758a1b3525