facebook twitter hatena line google mixi email

Aws/ec2/php

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

ec2サーバでphp5.4のphp-gdインストールしようとするとエラーとなる場合

$ sudo yum -y install php-gd.x86_64 --enablerepo=remi
Error: Package: php-gd-5.4.18-1.el6.remi.x86_64 (remi)
          Requires: libjpeg.so.62(LIBJPEG_6.2)(64bit)
sudo yum clean all
sudo yum install libjpeg-turbo --enablerepo=amzn-preview
sudo yum install php-gd.x86_64 --enablerepo=remi

ec2サーバでphp5.6のphp-pecl-memcachedインストールしようとするとエラーとなる場合

# yum install php-pecl-memcached.x86_64 --enablerepo=remi --enablerepo=remi-php56
Transaction check error:
 file /usr/lib64/libhashkit.so.2.0.0 conflicts between attempted installs of libmemcached-last-libs-1.0.18-2.el6.remi.x86_64 and libmemcached-1.0.8-2.6.amzn1.x86_64
 file /usr/lib64/libmemcachedprotocol.so.0.0.0 conflicts between attempted installs of libmemcached-last-libs-1.0.18-2.el6.remi.x86_64 and libmemcached-1.0.8-2.6.amzn1.x86_64
 file /usr/lib64/libmemcachedutil.so.2.0.0 conflicts between attempted installs of libmemcached-last-libs-1.0.18-2.el6.remi.x86_64 and libmemcached-1.0.8-2.6.amzn1.x86_64

実際はこのlibmemcached-last-libsのインストール時のエラー

# yum install libmemcached-last-libs.x86_64 --enablerepo=remi --enablerepo=remi-php56

amzn1のlibmemcachedを削除するとok

# yum remove libmemcached-1.0.8-2.6.amzn1.x86_64