facebook twitter hatena line google mixi email

Ios/swift/外部ライブラリ/インストール

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

macにcocoapadsをインストール

$ sudo gem update --system 
$ sudo gem install cocoapods

以下のようにエラーが返ってくる場合は

Operation not permitted - /usr/bin/fuzzy_match

このようにする(El Capitanからインストールフォルダが/usrの下へのインストールがアクセスできなくなったため)

$ sudo gem install -n /usr/local/bin cocoapods

cocoapodsのsetup

$ pod setup
> Setup completed

Podfile作成

プロジェクトDirの下で

$ pod init

以下Podfileのファイルができる

# platform :ios, '9.0'
target 'Helloworld' do
 # Comment this line if you're not using Swift and don't want to use dynamic frameworks
 use_frameworks!
 # Pods for Helloworld
 target 'HelloworldTests' do
   inherit! :search_paths
   # Pods for testing
 end
 target 'HelloworldUITests' do
   inherit! :search_paths
   # Pods for testing
 end
end

Podfile編集

こんな感じでライブラリ指定

$ vi Podfile
platform :ios,'9.0'
use_frameworks!
target 'Helloworld' do
        pod 'SDWebImage', '~>3.6'
end

podライブラリ更新処理

$ pod update

pod install

$ pod install
Analyzing dependencies
Downloading dependencies
Installing SDWebImage (3.8.1)
Generating Pods project
Integrating client project

プロジェクトファイル変更

Helloworld.xcodeprojではなく、 Helloworld.xcworkspaceを開く

でないと以下エラーが出る

/clang:-1: linker command failed with exit code 1 (use -v to see invocation)

参考