facebook twitter hatena line google mixi email

Linux/linuxインストール

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

ネットワーク設定

vi /etc/sysconfig/network

NETWORKING=yes
HOSTNAME=localhost.localdomain
GATEWAY=192.168.0.1

DHCP

vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:00:00:00:00:00
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

HWADDRは各自変更

IP固定

vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=none
HWADDR=00:00:00:00:00:00
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
NETMASK=255.255.255.0
IPADDR=192.168.0.3
GATEWAY=192.168.0.1

HWADDRは各自変更

ネットワーク再起動

/etc/init.d/network restart

必要そうなものインストール

yum update
yum install -y man
yum install -y make

必要そうなものphp

yum -y install php-pear

selinuxを切る(自動起動オフ

vi /etc/selinux/config
-SELINUX=enforcing
+SELINUX=disabled

でリブート

時刻合わせパッケージのインストール

# yum install ntp
# ntpdate ntp.nict.jp

yumが使えなくなった場合

yumはpythonでできており、pythonのバージョンがあわずに、以下エラーが出る。

current version of Python, which is:2.4.3
vi /usr/bin/yum