facebook twitter hatena line google mixi email

Php/laravel/laravel5/htmlcache Flatten編

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

インストール

vi composer.json

"require": {
   // 略
   "anahkiasen/flatten": "^1.1"
}
$ composer update anahkiasen/flatten

導入

vi config/app.php

'providers' => [
       // 略
       Flatten\FlattenServiceProvider::class,
],
'aliases' => [
       // 略
       'Flatten'   => Flatten\Facades\Flatten::class,
],

composerのupdateでエラーとなった

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
 Problem 1
   - Conclusion: remove laravel/framework 5.2.41
   - Conclusion: don't install laravel/framework 5.2.41
   - anahkiasen/flatten 1.1.0 requires illuminate/config 5.0.*|5.1.* -> satisfiable by illuminate/config[v5.0.0, v5.0.22, v5.0.25, v5.0.26, v5.0.28, v5.0.33, v5.0.4, v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].
   - anahkiasen/flatten 1.1.1 requires illuminate/config 5.0.*|5.1.* -> satisfiable by illuminate/config[v5.0.0, v5.0.22, v5.0.25, v5.0.26, v5.0.28, v5.0.33, v5.0.4, v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.6, v5.1.8].
   - don't install illuminate/config v5.0.0|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.0.22|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.0.25|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.0.26|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.0.28|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.0.33|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.0.4|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.1|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.13|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.16|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.2|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.20|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.22|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.25|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.28|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.30|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.31|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.6|don't install laravel/framework 5.2.41
   - don't install illuminate/config v5.1.8|don't install laravel/framework 5.2.41
   - Installation request for laravel/framework (locked at 5.2.41, required as 5.2.*) -> satisfiable by laravel/framework[5.2.41].
   - Installation request for anahkiasen/flatten ^1.1 -> satisfiable by anahkiasen/flatten[1.1.0, 1.1.1].

laravel5.2には対応してないのかな?未完成・・・