facebook twitter hatena line email

Unity/Firebase/Crashlytics

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

FirebaseCrashlyticsを6.15.2へバージョンアップしたとき

以下エラーが発生したとき

The Crashlytics build ID is missing. This occurs when Crashlytics tooling is absent from your app's build configuration. Please review Crashlytics onboarding instructions and ensure you have a valid Crashlytics account.

1. 以下ファイルを削除して・・・

Assets//Editor Default Resources/CrashlyticsSettings.asset
Assets//GeneratedLocalRepo/Firebase/m2repository/com/google/firebase/firebase-crashlytics-unity/6.15.2/firebase-crashlytics-unity-6.15.2.aar

2. ファイル内の文字を削除して・・・

Assets//Plugins/Android/mainTemplate.gradle

3. 一旦起動を確認すると、crashlyticsなしで、アプリ起動した動作した。

改めてFirebbaseCrashlytics.unitypackageをインストールしたら、同じエラーが起こった。

参考

旧版の場合

Unity/fabricのcrashlytics [ショートカット]


Unity アプリを Fabric Crashlytics から Firebase Crashlytics に移行する手順

https://firebase.google.com/docs/crashlytics/migrate-from-fabric?hl=ja