facebook twitter hatena line email

Unity/GoogleMobileAds/Mediation

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

nendの場合

こちらのunitypackage追加

https://developers.google.com/admob/unity/mediation/nend

以下Assets/GoogleMobileAds/Editor/NendMediationDependencies.xmlが追加されることを確認

<dependencies>
  <androidPackages>
    <androidPackage spec="com.google.ads.mediation:nend:5.4.2.0">
      <repositories>
        <repository>https://jcenter.bintray.com/</repository>
        <repository>http://fan-adn.github.io/nendSDK-Android-lib/library</repository>
      </repositories>
    </androidPackage>
  </androidPackages>

  <iosPods>
    <iosPod name="GoogleMobileAdsMediationNend" version="5.4.1.0">
      <sources>
        <source>https://github.com/CocoaPods/Specs</source>
      </sources>
    </iosPod>
  </iosPods>
</dependencies>

iosでGADMAdapterNendエラーが出ると

以下エラーが出るとき

<Google> Cannot find an ad network adapter with the name(s): GADMAdapterNend. Remember to link all required ad network adapters and SDKs, and set -ObjC in the 'Other Linker Flags' setting of your build target.

https://developers.google.com/admob/unity/mediation/nend が追加されてるか確認

iosのnendのpodfileのバージョン競合が起きるとき

[!] CocoaPods could not find compatible versions for pod "NendSDK_iOS":
  In Podfile:
    GoogleMobileAdsMediationNend (= 5.4.1.0) was resolved to 5.4.1.0, which depends on
      NendSDK_iOS (= 5.4.1)

    NendSDK_iOS (~> 5.3.0)

Specs satisfying the `NendSDK_iOS (~> 5.3.0), NendSDK_iOS (= 5.4.1)` dependency were found, but they required a higher minimum deployment target.

nendのバージョンを合わせる