facebook twitter hatena line google mixi email

Unity/GoogleMobileSDK/ライブラリ自動読み込み

提供: 初心者エンジニアの簡易メモ
移動: 案内検索

準備

https://github.com/googlesamples/unity-jar-resolver

play-services-resolver-1.2.89.0.unitypackageをDL

play-services-resolver-1.2.89.0.unitypackageをAssets/ImortPackage/CustomPackageからインストールする

インストールに失敗する場合

unity/GoogleMobileAds/基本 [ショートカット]

play-services-resolverがこのライブラリに付属してるので、それをインストールする

自動読み込み

androidでのmavenやiosでのcocoapodsなどでライブラリを呼びたい場合などに使用。

  1. 以下のようにandroidであればpackageurlを変更し、iosであればbundleやライブラリ名を変更すれば適用できる。
<dependencies>
  <androidPackages>
    <androidPackage spec="com.google.android.gms:play-services-games:9.8.0">
      <androidSdkPackageIds>
        <androidSdkPackageId>extra-google-m2repository</androidSdkPackageId>
      </androidSdkPackageIds>
      <repositories>
        <repository>https://maven.google.com</repository>
      </repositories>
    </androidPackage>
  </androidPackages>
  <iosPods>
    <iosPod name="Google-Mobile-Ads-SDK" version="~> 7.0" bitcodeEnabled="true"
            minTargetSdk="6.0">
      <sources>
        <source>https://github.com/CocoaPods/Specs</source>
      </sources>
    </iosPod>
  </iosPods>
</dependencies>

コメント付きは以下参照 https://github.com/googlesamples/unity-jar-resolver/blob/master/sample/Assets/PlayServicesResolver/Editor/SampleDependencies.xml

カスタムで自動読込したい場合

okhttp3を入れる例 (できなかったので、未完成)

<dependencies>
  <!-- Android  -->
  <androidPackages>
    <androidPackage spec="com.squareup.okhttp3:3.7.0">
      <androidSdkPackageIds>
        <androidSdkPackageId>okhttp</androidSdkPackageId>
      </androidSdkPackageIds>
      <repositories>
        <repository>https://mvnrepository.com/artifact</repository>
      </repositories>
    </androidPackage>
  </androidPackages>
  <!-- iOS  -->
  <iosPods>
    <iosPod name="Google-Mobile-Ads-SDK" version="~> 7.0" bitcodeEnabled="true"
            minTargetSdk="6.0">
      <sources>
        <source>https://github.com/CocoaPods/Specs</source>
      </sources>
    </iosPod>
  </iosPods>
</dependencies>

以下にあるjarがAssets/Plugins/Androidの下にされる https://mvnrepository.com/artifact/com.squareup.okhttp3/okhttp/3.7.0 https://mvnrepository.com/artifact/com.squareup.okio/okio/1.12.0

iosPodの属性

<iosPod name="Google-Mobile-Ads-SDK" version="~> 7.0" bitcodeEnabled="true"
           minTargetSdk="6.0">
     <sources>
       <source>https://github.com/CocoaPods/Specs</source>
     </sources>
<iosPod>

iosプロジェクトのPodfileのファイルにフォーマットを変えて出力される

source 'https://github.com/CocoaPods/Specs.git'
source 'https://github.com/CocoaPods/Specs'
platform :ios, '9.0'
target 'Unity-iPhone' do
pod 'Google-Mobile-Ads-SDK', '~> 7.0'
end

処理csは以下の通り、 https://github.com/googlesamples/unity-jar-resolver/blob/master/source/IOSResolver/src/IOSResolver.cs